[maemo-users] Write access for MMC

From: Eero Tamminen eero.tamminen at nokia.com
Date: Wed Oct 15 15:42:03 EEST 2008

ext Shivkumar Chandrasekaran wrote:
>>>> I have a 770 with OS2007 Hacker's edition with a 1GB removable card.
>>>> Everything worked fine until yesterday when I suddenly lost write-access
>>>> to the card. So I can no longer do backups or write or remove files from
>>>> the File Manager. I tried connecting it to my Linux machine using the
>>>> USB cable, but the Linux machine also insists that the file system on
>>>> the USB drive is read-only (so I could not delete files for example from
>>>> linux terminal, even with super-user permission).
>>>> Can anyone give me some advice so that I can re-acquire write access?
>> the file system card can be corrupted and needs an fsck.
> Any idea how I can do that? When I chose "Memory card -> mmc2 ->
> Format ..." from File Manager it tells me that the memory card is in
> use. I tried booting up without the memory card and then inserted it
> later to no effect.

Metalayer-crawler media indexer is probably going through it.
If waiting a while doesn't help, you can disable the crawler
using /etc/init.d/ script (as root).

	- Eero

More information about the maemo-users mailing list