[maemo-users] Maemo 5 - 802.1x PEAP+MSCHAPv2

From: Pali Rohár pali.rohar at gmail.com
Date: Tue Feb 11 19:03:21 UTC 2014
2014-02-11 19:48 GMT+01:00 Sicelo <absicsz at gmail.com>:
> I need to connect to an enterprise network requiring the use of PEAP+MSCHAPv2. Clients do not need to have a certificate installed. Authentication is via domain username and password. I have tried all the options suggested on talk.maemo.org, and still no luck. Syslog always says 'eap authentication failed.' My username works perfectly on almost any other device.
> So I setup FreeRadius on my debian pc, and set my cheap AP for Radius authentication. N900 still can't connect to this. The FreeRadius log shows an issue with 'bad certificate' whether or not I have the provided certificates on device.
> Any ideas would help. I suppose someone has at least once got N900 to connect to such a network via FreeRadius.
> _______________________________________________
> maemo-users mailing list
> maemo-users at maemo.org
> https://lists.maemo.org/mailman/listinfo/maemo-users

There was problem with self signed certificates and certificates which
did not have stored CA in maemo certman. I do not remember if this was
fixed or not. Try to check if both CA and certificate itself are
installed in Settings --> Certificates.

I do not have any problem with connecting to wifi WPA2 EAP TTLS+GTC or
EAP PEAP+MSCHAPv2. Try to check also syslog, if nokias eapd daemon did
not write any error message.

Other option is to use wpa_supplicant (which is in extras-devel) and
connect manually to wifi network like on any linux machine.

I'm using wpa_supplicant for ethernet 802.1X authentification with usb
ethernet card connected to n900 in usb host mode and there is no

Pali Rohár
pali.rohar at gmail.com
More information about the maemo-users mailing list