[maemo-developers] can't find maemomm in 3.0 repo

From: Johan Bilien jobi at via.ecp.fr
Date: Tue Mar 27 19:43:23 EEST 2007
On Tue, Mar 27, 2007, 3rdshift at comcast.net wrote:
> at least on the surface, that doesn't seem to be the case. 
> An application I'm trying to install depends among others on libsigc++-2.0-0c2a. The application's category is properly set to 'user/other' - so there is no conflict there. Also, my application's dependencies are set to ${shlibs:Depends}.
> The libsigc++-2.0-0c2a's category is set to 'devel' - which make it 'invisible' but as you said 'installable as a dependency'. When I try to install my application with Application Manager, its 'Status' is marked as 'Not installable' and the 'Problems' tab lists the following causes:
> Unable to install application
> Application packages missing:
>     hildon-fmmm
>     hildon-libsmm
>     libglibmm-2.4.-1c2a
>     libgtkmm-2.4-1c2a
>     libsigc++-2.0-0c2a (>= 2.0.2)

Are you installing the package as a file, or from a repository?

I think Application Installer does not install dependencies when
installing from a standalone file. Marius correct me if I'm wrong :)

Johan Bilien
<jobi at via.ecp.fr>

More information about the maemo-developers mailing list