[maemo-developers] Autobuilder repository priority ?

From: Ed Bartosh bartosh at gmail.com
Date: Sun Nov 1 09:23:13 EET 2009
2009/10/31 Attila Csipa <maemo at csipa.in.rs>:
> I have a small issue with the autobuilder. The whole thing started out by
> having a package that compiled nice in the SDK but not in the autobuilder due
> to a versioning mismatch (in my case python-dbus, but it's a generic problem
> as you'll see). After some snooping around, I realized the problem was that
> the SDK had 0.83.0-1maemo1 in fremantle/tools/free (and that's what got used
> when compiling in the SDK), however, the autobuilder insists on using
> 0.83.0-1maemo3 from fremantle/free (-devel).

You can try to use python2.5-dbus instead of python-dbus to work
around the problem. python2.5-dbus is just a meta package, but it
presents only in SDK, which might allow you to avoid installing
python-dbus from extras-devel.

PS: It's just a workaround, not more than that. We can continue our discussion.

More information about the maemo-developers mailing list